Update your Kindle today or it could be unusable.
0shares
Amazon-Kindle-logo

Update your Kindle today or it could be unusable.

If you have a Kindle then you may have already seen this important notice about updating it, if not then you should definitely take a moment to do it today otherwise it could become unusable for a short period of time.

 

The update is crucial if you wish to keep using your Kindle and the issue affects all products made before 2013.  These include Kindle Paperwhite 5th generation from 2012, Kindle DX 2nd generation from 2009, and Kindle Keyboard 3rd generation from 2010. Regular Kindles, generations 1, 2, 3 and 4, from 2007, 2009, 2011 and 2012, also need to be updated. 

Don’t panic though! It’s not difficult to update and it will only take a few minutes out of your day. All you have to do is go to your Kindle’s menu from the home screen and press ‘Sync and check items’ .

If It’s already too late to update your device then you should see the message.Your Kindle is unable to connect at this time. Please make sure you are within wireless range and try again. If the problem persists, please restart your Kindle from the Menu in Settings and try again.”

Again, don’t worry because all is not lost. It just gets slightly more complicated and you’ll need to do it manually with a USB cable.

CLICK HERE for full details on how to manually update your Kindle on Amazon’s website. 

Are you thinking of buying a Kindle? See the full selection of latest products here.

 

 

You may also like
Share this article
0shares
Leave a comment

Leave a Reply